Welcome to the Tiger Owners Club

Home - Forum - Links - Downloads - Privacy Policy

Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Badger54

Avatar / Picture

Registered Users
Registered:
Posts: 22
Reply with quote  #1 
The speedo on my Super 6 has suddenly decided to pack up.
Anyone got any ideas where I should start looking please?
0
Carnoustiecat

Avatar / Picture

Forum Donor 2015
Registered:
Posts: 168
Reply with quote  #2 

This would very much depend whether it’s a cable or electronic speedo.

If its a cable you have either the drive in the gearbox, the cable, or the speedo head. I would start by checking the cable as it’s probably the easiest to check, it might even just have come off at one end or the other?

If it’s electronic there‘s been a couple of posts recently on here about faults or issues, check them they might be of help.

Scott


__________________
TIGER CAT E1 2L ZETEC TWIN 45 WEBERS
0
MarkCopsey

Avatar / Picture

Registered Users
Registered:
Posts: 1,887
Reply with quote  #3 
Yep, check which type.

Cable - likely the cable has broken (or the drive)

Electronic - likely the bracket has moved so to far away to pic up the magnets (or the magnets have come off, unlikely both would have come off though, so if it's not working at all, probably not this).

__________________
Tiger Super Six (now Avon!)
0
Badger54

Avatar / Picture

Registered Users
Registered:
Posts: 22
Reply with quote  #4 
Thanks for your help Gentlemen. the drive had disconnected itself from the gearbox.
The added bonus was that while I was fixing it I also managed to reconnect the reversing light cables.
Happy days! 
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.


  © Copyright 2000-2019 Tiger Owners Club