Welcome to the Tiger Owners Club

Home - Forum - Links - Downloads - Privacy Policy

Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #1 
Hi all,
I've finally tried hooking up my Megajolt to try uploading a map. 
It's plugged straight into the back of a PC that has a built in COM port (thankfully, because the USB adapter I got for the laptop doesn't work), but whenever I try to Get or Write the ignition configuration, I just get a "Timeout reading cylinder count" message at the bottom of the screen. 

Does anyone have any ideas what might be going wrong please? 
I don't know if it should, but the green light on the front of the MJ doesn't light up.

The guys who are finishing my build are waiting for this, as it's pretty much the last thing that needs doing before it can go off for IVA now. 

Thanks
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #2 
As a footnote, Device Manager says the com port is COM1, and this is what the MJ configurator is set to.

If I change the configurator to use COM2, I get a "could not open port" error. 
0
TOC_Admin

Super Moderators
Registered:
Posts: 309
Reply with quote  #3 
The green light indicates power is getting to the unit.  It should be connected to an ignition feed, so it is only powered when the ignition is on, so start with the basics:

1) Is the ignition on?

2) Check the supply and earth are wired to the correct pins on the MJ with a multimeter by disconnecting the MJ.

2a) Check there is power between the power pin and the cars chassis, it should show around 12-12.5v in voltage mode.  If not, check fuses, wiring etc for the supply using continuity mode or resistance mode on the multimeter - the resistance should be 0 ohms.

2b) Check there is power between the power pin and the earth pin, it should show around 12-12.5v in voltage mode.  If not, check the earth wiring - did you earth the other end of the wire to a suitable point on the chassis?  Again, use continuity mode or resistance mode - the resistance should be 0 ohms.
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #4 
Thanks for that, and the MJ isn't in the car, but sat on my desk, with no incoming power....
I had stupidly thought that I would just need the RS232 lead plugged in, and the 16 pin Molex connector is in the car 200 miles away.
So, I have a replacement on order, so I can get it powered up, and hopefully get a map unloaded onto it!!

Will let you know if I succeed.
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #5 
Quote:
Originally Posted by Wigster
Thanks for that, and the MJ isn't in the car, but sat on my desk, with no incoming power....
I had stupidly thought that I would just need the RS232 lead plugged in, and the 16 pin Molex connector is in the car 200 miles away.
So, I have a replacement on order, so I can get it powered up, and hopefully get a map unloaded onto it!!

Will let you know if I succeed.


And I did succeed! Just hooked up a 12v supply, and job done. 
0
TOC_Admin

Super Moderators
Registered:
Posts: 309
Reply with quote  #6 
[smile] [thumb]
0
JimM

Avatar / Picture

Registered Users
Registered:
Posts: 1,060
Reply with quote  #7 
What revision of Megajolt do you have.

__________________
ST170- VVC Controller - R1Carbs - Megajolt - CatXL
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #8 
Quote:
Originally Posted by JimM
What revision of Megajolt do you have.


It's a t/e
0
JimM

Avatar / Picture

Registered Users
Registered:
Posts: 1,060
Reply with quote  #9 
What is a T/e ....  
My units was built by a fellow Tiger member back in 2007.  Revision 3.

__________________
ST170- VVC Controller - R1Carbs - Megajolt - CatXL
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #10 
It's one of these Jim

https://www.autosportlabs.com/product/megajolte-mk2_crank_fired_ignition/
0
JimM

Avatar / Picture

Registered Users
Registered:
Posts: 1,060
Reply with quote  #11 
Mmmmmm,

$200 dollars - might be worth buying a new one then getting it mapped for my ST170 engine as it looks as though it should be easy to hook up.
USB connection and no drivers should make it universal to program.

I'll have a think on this ….

cheers
Jim

__________________
ST170- VVC Controller - R1Carbs - Megajolt - CatXL
0
JimM

Avatar / Picture

Registered Users
Registered:
Posts: 1,060
Reply with quote  #12 

Brief update ....

Purchased a Megajolt Lite from Ebay ... £105 ... decided it was worth a punt.

Checked the unit on a bench and confirmed I could read / write Code to the unit.
Loaded a Zetec map that I picked up from a fellow Tiger owner.

Unplugged the cable harness from my old Megajolt and added to the Ebay one.
Stuck it temporarily behind my dashboard ...

Went for a blat and all is good [biggrin]

When I get some time I will remove my old unit and fully install the new one.
Then arrange a slot with a Dyno tuner to see if I can get full power from the ST lump and to eliminate fuel smell when on full Blat Mode.

cheers
Jim


__________________
ST170- VVC Controller - R1Carbs - Megajolt - CatXL
0
Wigster

Avatar / Picture

Registered Users
Registered:
Posts: 964
Reply with quote  #13 
Good stuff Jim, let us know how you get on. 

Which map did you use? I had a choice of 2.0 with MAF sensor, or 1.8 with TPS. 
My setup is 2.0 with tps, so went with the 1.8/tps option

All I know though is that it works well enough to fire the car up, because it's still away getting finished off. 
0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.


  © Copyright 2000-2019 Tiger Owners Club