Welcome to the Tiger Owners Club

Home - Forum - Links - Downloads - Privacy Policy

Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Benjiwool

Registered Users
Registered:
Posts: 16
Reply with quote  #1 
I've not a great deal of experience with carbs at all but can any one advise a little, my car pulls fairly well wen pushing on, but its the initial push on the accelerator that's causing the engine to hesitate/bogg/splutter for a second or 2 then it takes off fine....bit like cruising at 50 then trying to move to 60 it will seem Jerky an not smooth at all. , its 2.0 zetec, old kent cams an polished head if thay makes any difference, theirs just no smoothness with rolling on slowly
0
Schrodinger

Avatar / Picture

Registered Users
Registered:
Posts: 717
Reply with quote  #2 
What carbs are you using, ISTR that Weber carbs could have a problem with a zetec is they didn't have sufficient progression holes.
__________________
Keith Aviemore yet again, was Suffolk again
was Aviemore, Scotland
Was Cotton, Suffolk
0
Schrodinger

Avatar / Picture

Registered Users
Registered:
Posts: 717
Reply with quote  #3 
What carbs are you using, ISTR that Weber carbs could have a problem with a zetec if they didn't have sufficient progression holes.
__________________
Keith Aviemore yet again, was Suffolk again
was Aviemore, Scotland
Was Cotton, Suffolk
0
Benjiwool

Registered Users
Registered:
Posts: 16
Reply with quote  #4 
Weber 45s its fine wen sat still an give it a rev, but it only happens wen driving, it will cough a fart for a second or 2 then pull off as you would expect
0
vji4058

Registered Users
Registered:
Posts: 1,232
Reply with quote  #5 
Has this just started to develop this problem and been fine previously ?
0
Benjiwool

Registered Users
Registered:
Posts: 16
Reply with quote  #6 
I've only had it about a month an its been like it scinc rive had it. I don't notice it to much if out booting it, more wen stuck behind traffic, or go from a 30 zone to 50/60zone or even 30 to 35 its that initial press were i get it like its starved or getting to much fuel then it thinks cough cough an goes. Disnt no if their was any thing to look or screws to turn that might help smooth it out, an pull away better, soon as it passes the splutter it dont half pull right up to past 7k if you will let it
0
snippy

Avatar / Picture

Registered Users
Registered:
Posts: 573
Reply with quote  #7 
I had a similar problem years ago with my zetec. I had a Filter King Fuel regulator fitted and when I floored it, it spluttered for a moment but gentle acceleration was fine. It was fuel starvation. I removed the regulator and it cured the problem. If you have a regulator fitted you could try removing it and testing the car without it. As others have said webers need an extra progression hole for a zetec. A couple of things to think about.
__________________
Tiger Cat E1 - 2.0 Zetec, Kent Cams, ZX6r Bike carbs, megajolt
Tiger GTA - 2.0 Zetec, Twin Webers, OMEX ECU

0
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.


  © Copyright 2000-2019 Tiger Owners Club